Introduction
It is common for reports from different sources to have varying results, as different systems count events differently. Below, we provide reasons for these variations and possible solutions.
Causes
Variations can be the result of; click the + to see more information:
Solutions
If there are differences between your internal analytics and our reports, we recommend you take the following steps:
- Familiarize yourself with the attribution models of the platforms you are comparing and understand their key differences.
- Compare reports for a limited period, such as one or two days.
- Check for clicks and orders that we have not recorded. Investigate the reason why those were not included in Rakuten reports. We provide guidance on how to do so below.
Investigating Reports
If you recorded an order but cannot find it in Rakuten reports, add the Transaction Created on Date column to the reports. This column provides the click date. Compare this date to the date of purchase displayed in the Transaction Date column. A significant gap could indicate that you are not accounting for return visits within the attribution window.
If you find that some orders tagged as affiliate orders do not show up at all in the Rakuten platform, check that:
- Correct tracking was appended to the links for us to track the sale.
- The order was considered non-commissionable.
- You did not use third-party parameters in your links. These parameters are stripped during the redirect, which may cause issues. The only custom parameters we allow are u1 and u5.
Rakuten versus GA4 Differences in Data Perspective
Traffic source attribution has changed from universal analytics to Google Analytics 4 (GA4). This can impact how advertisers attribute conversions from cash back and loyalty publishers in their GA4 account. If the advertiser does not agree with Rakuten’s in-channel attribution method compared to what they see in GA4, this may lead to additional cancellations.
GA4 attributes the conversion to the last session initiator. If an affiliate click occurs after the user is already on site, it is ignored and logged as an event, not as a new affiliate session, and not attributed to the conversion in case of a conversion. This is the case when using the Traffic Acquisition report in the GA4 Reports section.
GA4 is not consistent with their attribution logic. For example, if you use the Attribution Model Comparison report in the Advertising section, Google uses the old non-direct last-click attribution method and GA4 reports different numbers.
Additionally, GA4 uses a new data-driven attribution model to assess the impact on conversion rate when assigning value. However, the attribution model can be changed to Last Click under attribution settings.
GA4 also allows different settings for its event lookback window. For conversion attribution, this can be set to 30, 60, or 90 days, and it can be different from the Return Days set for affiliate offers.
Keep in mind that changing the attribution settings in GA4 impacts the whole GA property and all traffic sources and should only be considered very carefully.
Next Steps
After comparing the data, you should have an understanding of the differences between your reporting and Rakuten Advertising reports. Use this analysis to compare the reports going forward.
If you find issues with how orders are reported, contact Customer Support.
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